NCTWavChunksEditor2Lib

NCTAudioStudio2 ActiveX DLLs
NCTWavChunksEditor2 ActiveX DLL

Version 2.2

NCTWavChunksEditor2 ActiveX DLL allows to edit information "chunks" in an audio file with The Radio Industry's Traffic Data WAVE File Standard specification.

The Cart Chunk standard allows users to embed the common labeling information that radio users need, directly into a WAVE file. Based on the RIFF file format, the Cart Chunk format is a standard that allows additional metadata to be attached as an integral part of a WAVE file in the form of "chunks", or integral units of data. For more information about this standard see http://www.cartchunk.org.

NCTWavChunksEditor2 is a part of the NCTAudioStudio2 package.

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


WavChunksEditor2 properties

WavChunksEditor2 properties

Property | Type | Default | Description
Bitrate | BitrateConstants |  | Read-only property that returns the bitrate of the audio file, opened by OpenFile method or created by CreateFile method.
BitsPerSample | Integer |  | Read-only property that returns the number of bits per sample in the audio file, opened by OpenFile method or created by CreateFile method.
BroadcastAudioExtension | BroadcastAudioExtension |  | Gets or sets broadcast information.
CartAudioExtension | CartAudioExtension |  | Gets or sets cart extension information.
Channels | ChannelsConstants |  | Read-only property that returns the number of channels of the audio file, opened by OpenFile method or created by CreateFile method. Mono data uses one channel and stereo data uses two channels.
CuePointCount | Long |  | Read-only property that returns the number of cue points.
CuePointInfo | CuePoint |  | Gets or sets cue point information.
CuePointNum | Long |  | Gets or sets the number of the current cue point.
DataPosition | Long |  | Gets or sets the current position of the data in the file.
DataSize | Long |  | Read-only property that returns the size of the file opened by OpenFile method.
ExtraInformation | ExtraInformation |  | Gets or sets extra information.
FormatACM | ACMFormat |  | Gets or sets information about ACM format of opened or created audio file.
FormatACM_cbArray | Byte() |  | Gets or sets an array that specifies extra information in the ACM format header.
Frequency | FrequencyConstants |  | Read-only property that returns the frequency of the audio file, opened by OpenFile method or created by CreateFile method.

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT Company Ltd. http://www.nctsoft.com


Bitrate property (WavChunksEditor2)

Bitrate property (WavChunksEditor2 object)

Read-only property that returns the bitrate of the audio file, opened by OpenFile method or created by CreateFile method.

Property type

A BitrateConstants value.

Syntax

object.Bitrate [= value]

The Bitrate property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | BitrateConstants | Bitrate is in bits per second.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

BitsPerSample | Channels | DataSize | Frequency

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


BitsPerSample property (WavChunksEditor2)

BitsPerSample property (WavChunksEditor2 object)

Read-only property that returns the number of bits per sample in the audio file, opened by OpenFile method or created by CreateFile method.

Property type

An Integer value.

Syntax

object.BitsPerSample [= value]

The BitsPerSample property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | Integer | Number of bits per sample.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

Bitrate | B Channels | DataSize | Frequency

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


BroadcastAudioExtension property (WavChunksEditor2)

BroadcastAudioExtension property (WavChunksEditor2 object)

Gets or sets broadcast information.

Property type

A BroadcastAudioExtension value.

Syntax

object.BroadcastAudioExtension [= value]

The BroadcastAudioExtension property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | BroadcastAudioExtension | Structure for broadcast parameters.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


CartAudioExtension property (WavChunksEditor2)

CartAudioExtension property (WavChunksEditor2 object)

Gets or sets cart extension information.

Property type

A CartAudioExtension value.

Syntax

object.CartAudioExtension [= value]

The CartAudioExtension property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | CartAudioExtension | Structure for cart extension parameters.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


Channels property (WavChunksEditor2)

Channels property (WavChunksEditor2 object)

Read-only property that returns the number of channels of the audio file, opened by OpenFile method or created by CreateFile method. Mono data uses one channel and stereo data uses two channels.

Property type

A ChannelsConstants value.

Syntax

object.Channels [= value]

The Channels property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | ChannelsConstants | Number of channels.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

Bitrate | BitsPerSample | DataSize | Frequency

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


CuePointCount property (WavChunksEditor2)

CuePointCount property (WavChunksEditor2 object)

Read-only property that returns the number of cue points.

Property type

A Long value.

Syntax

object.CuePointCount [= value]

The CuePointCount property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | Long | The number of cue points.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

CuePointInfo | CuePointNum

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


CuePointInfo property (WavChunksEditor2)

CuePointInfo property (WavChunksEditor2 object)

Gets or sets cue point information.

Property type

A CuePoint value.

Syntax

object.CuePointInfo [= value]

The CuePointInfo property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | CuePoint | Structure for cue point parameters.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

CuePointCount | CuePointNum

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


CuePointNum property (WavChunksEditor2)

CuePointNum property (WavChunksEditor2 object)

Gets or sets the number of the current cue point.

Property type

A Long value.

Syntax

object.CuePointNum [= value]

The CuePointNum property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | Long | The number of the current cue point.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

CuePointCount | CuePointInfo

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


DataPosition property (WavChunksEditor2)

DataPosition property (WavChunksEditor2 object)

Gets or sets the current position of the data in the file.

Property type

A Long value.

Syntax

object.DataPosition [= value]

The DataPosition property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | Long | Number of samples from the beginning of the file to the current position.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

... ' Filling of structures fields
Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

File.BroadcastAudioExtension = Broadcast
File.CartAudioExtension = Cart
File.ExtraInformation = Extra
File.FormatACM = Format
...
File.DataPosition = File.DataSize / 2
'Replacing current position to the center of opened file.
...
File.CloseFile

See Also:

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


DataSize property (WavChunksEditor2)

DataSize property (WavChunksEditor2 object)

Read-only property that returns the size of the file opened by OpenFile method.

Property type

A Long value.

Syntax

object.DataSize [= value]

The DataSize property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | Long | File size in samples.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

Bitrate | BitsPerSample | Channels | Frequency

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


ExtraInformation property (WavChunksEditor2)

ExtraInformation property (WavChunksEditor2 object)

Gets or sets extra information.

Property type

A ExtraInformation value.

Syntax

object.ExtraInformation [= value]

The ExtraInformation property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | ExtraInformation | Structure for extra information.

Remarks:

Extra information is a registered global form type that can store information that helps identify the contents of the chunk. This information is useful but does not affect the way a program interprets the file; examples are copyright information and comments.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


FormatACM property (WavChunksEditor2)

FormatACM property (WavChunksEditor2 object)

Gets or sets information about ACM format.

Property type

A ACMFormat value.

Syntax

object.FormatACM [= value]

The FormatACM property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | ACMFormat | Structure for ACM format information.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

FormatACM_cbArray

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


FormatACM_cbArray property (WavChunksEditor2)

FormatACM_cbArray property (WavChunksEditor2 object)

Gets or sets an array that specifies extra information in the ACM format header.

Property type

A Byte() value.

Syntax

object.FormatACM_cbArray [= value]

The FormatACM_cbArray property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | Byte() | The array of the extra information in the format header.

Example:

' VB sample where WChEditor2 is an WavChunksEditor2 object.
Format = WChEditor2.FormatACM
tcbArray.Text = ""

For i = 0 To Format.cbSize - 1
tcbArray.Text = tcbArray.Text + Str(WChEditor2.FormatACM_cbArray(i)) + " "
Next i

See Also:

FormatACM

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


Frequency property (WavChunksEditor2)

Frequency property (WavChunksEditor2 object)

Read-only property that returns the frequency of the audio file, opened by OpenFile method or created by CreateFile method.

Property type

A FrequencyConstants value.

Syntax

object.Frequency [= value]

The Frequency property syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
value | FrequencyConstants | The frequency of the audio file.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

Bitrate | BitsPerSample | Channels | DataSize

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


WavChunksEditor2 methods

WavChunksEditor2 methods

Method | Description
CloseFile | Closes the opened audio file.
CreateFile | Creates an output file.
DeleteCuePoint | Deletes the current cue point.
InsertCuePoint | Adds cue point information to the cue point list.
OpenFile | Opens an audio file for reading.
ReadDataArray | Gets data array read from the current audio file opened by OpenFile method.
Register | Enters user name and registration password to disable About window.
WriteDataArray | Writes data array to the current audio file opened by OpenFile method or created by CreateFile method.

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT Company Ltd. http://www.nctsoft.com


CloseFile method

CloseFile method (WavChunksEditor2 object)

Closes the opened audio file.

Syntax

object.CloseFile()

The CloseFile method syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.

Remarks:

This method can be applied only after OpenFile or CreateFile method.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

CreateFile | OpenFile

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


CreateFile method

CreateFile method (WavChunksEditor2 object)

Creates an output file.

Syntax

object.CreateFile(fileName As String)

The CreateFile method syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
fileName | String | Pathname of audio file.

Remarks:

Audio file can be closed by CloseFile method.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

... ' Filling of structures fields
Set File = New WavChunksEditor2

File.CreateFile "c:\track01.wav"

File.BroadcastAudioExtension = Broadcast
File.CartAudioExtension = Cart
File.ExtraInformation = Extra
File.FormatACM = Format

File.CloseFile

See Also:

CloseFile | OpenFile

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


DeleteCuePoint method

DeleteCuePoint method (WavChunksEditor2 object)

Deletes the current cue point.

Syntax

object.DeleteCuePoint

The DeleteCuePoint method syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.

Remarks:

You can insert a new cue point by InsertCuePoint method.

Example:

' VB sample where WChEditor2 is an WavChunksEditor2 object.
i = udCueIndex.Value
If i < CueCounts And i > 1 Then
    CuePoints(i).Position = Int(tPosition.Text)
    CuePoints(i).Length = tLength.Text
    CuePoints(i).Label = tLabel.Text
    CuePoints(i).Note = tNote.Text
    CuePoints(i).Text = tText.Text
End If
WChEditor2.InsertCuePoint CuePoints
...
WChEditor2.DeleteCuePoint

See Also:

InsertCuePoint

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


InsertCuePoint method

InsertCuePoint method (WavChunksEditor2 object)

Adds cue point information to the cue point list.

Syntax

object.InsertCuePoint(newCuePoint As CuePoint)

The InsertCuePoint method syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
newCuePoint | CuePoint | Structure for cue point parameters.

Remarks:

You can delete this cue point by DeleteCuePoint method.

Example:

' VB sample where WChEditor2 is an WavChunksEditor2 object.
i = udCueIndex.Value
If i < CueCounts And i > 1 Then
    CuePoints(i).Position = Int(tPosition.Text)
    CuePoints(i).Length = tLength.Text
    CuePoints(i).Label = tLabel.Text
    CuePoints(i).Note = tNote.Text
    CuePoints(i).Text = tText.Text
End If
WChEditor2.InsertCuePoint CuePoints

See Also:

DeleteCuePoint

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


OpenFile method

OpenFile method (WavChunksEditor2 object)

Opens an audio file for reading.

Syntax

object.OpenFile(fileName As String)

The OpenFile method syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
fileName | String | Pathname of audio file.

Remarks:

Audio file can be closed by CloseFile method.

Example:

Dim Bitrate, BitsPerSample, Channels, Size As Long

Dim File As WavChunksEditor2

Dim Broadcast As BroadcastAudioExtension
Dim Cart As CartAudioExtension
Dim Format As ACMFormat
Dim Extra As ExtraInformation

Set File = New WavChunksEditor2

File.OpenFile "c:\track01.wav"

Broadcast = File.BroadcastAudioExtension
Cart = File.CartAudioExtension
Extra = File.ExtraInformation
Format = File.FormatACM

Bitrate = File.Bitrate
BitsPerSample = File.BitsPerSample
Channels = File.Channels
Size = File.DataSize
Frequency = File.Frequency

CueCounts = File.CuePointCount
If CueCounts > 0 Then
ReDim CuePoints(1 To CueCounts) As CuePoint

For i = 1 To CueCounts
File.CuePointNum = i
CuePoints(i) = File.CuePointInfo
Next i
End If

File.CloseFile

See Also:

CloseFile | CreateFile

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


ReadDataArray method

ReadDataArray method (WavChunksEditor2 object)

Gets data array read from the current audio file opened by OpenFile method.

Return Type

A Byte value.

Syntax

ReadDataArray() = object.ReadDataArray(size As Long)

The ReadDataArray method syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
size | Long | The size of the reading audio data array.
ReadDataArray() | Byte | The reading audio data array.

Example:

' VB sample where FileIn, FileOut is an WavChunksEditor2 object.
FileIn.OpenFile "c:\track01.wav"
Format = FileIn.FormatACM

FileOut.FormatACM = Format
FileOut.CartAudioExtension = Cart
FileOut.BroadcastAudioExtension = Broadcast
FileOut.ExtraInformation = Extra

FileOut.CreateFile "c:\track02.wav"

While (1)
Data() = FileIn.ReadDataArray(10000)
If (UBound(Data) < 1) Then GoTo 1
FileOut.WriteDataArray Data()
Wend
1:
FileIn.CloseFile
FileOut.CloseFile

See Also:

WriteDataArray

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


Register method

Register method (WavChunksEditor2 object)

Enters user name and registration password to disable About window.

Syntax

object.Register(strUser As String, strPassword As String)

The Register method syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
strUser | String | User name. You get a registration user name after the registration.
strPassword | String | Password string. You get a registration password after the registration.

Example:

' VB sample where WChEditor is an WavChunksEditor2 object.
WChEditor.Register "XXX", "XXX"

See Also:

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


WriteDataArray method

WriteDataArray method (WavChunksEditor2 object)

Writes data array to the current audio file opened by OpenFile method or created by CreateFile method.

Syntax

object.WriteDataArray(Array() As Byte)

The WriteDataArray method syntax has these parts:

Part | Type | Description
object | WavChunksEditor2 | An expression evaluating to an object.
Array() | Byte | The data array.

Example:

' VB sample where FileIn, FileOut is an WavChunksEditor2 object.
FileIn.OpenFile "c:\track01.wav"
Format = FileIn.FormatACM

FileOut.FormatACM = Format
FileOut.CartAudioExtension = Cart
FileOut.BroadcastAudioExtension = Broadcast
FileOut.ExtraInformation = Extra

FileOut.CreateFile "c:\track02.wav"

While (1)
Data() = FileIn.ReadDataArray(10000)
If (UBound(Data) < 1) Then GoTo 1
FileOut.WriteDataArray Data()
Wend
1:
FileIn.CloseFile
FileOut.CloseFile

See Also:

ReadDataArray

Applies to: WavChunksEditor2

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com


NCTWavChunksEditor2 constants

NCTWavChunksEditor2 constants

Constants | Description
BasicTimerConstants | These are the constants for the following property and structure: PostTimer_Usage property (WavChunksEditor2), CartAudioTimer structure.
BitrateConstants | These are the constants for the Bitrate property (WavChunksEditor2).
ChannelsConstants | These are the constants for the Channels property (WavChunksEditor2).
FrequencyConstants | These are the constants for the Frequency property (WavChunksEditor2).

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT Company Ltd. http://www.nctsoft.com


BasicTimerConstants enumeration

BasicTimerConstants enumeration

These are the constants for the following property and structure: PostTimer_Usage property (WavChunksEditor2), CartAudioTimer structure.

Members

Part | Value | Description
NONE | 0 | Unused.
SEGs | 1 | Segue start timer.
SEGe | 2 | Segue end timer.
AUDs | 3 | Audio boundary (the start of audio following silence).
AUDe | 4 | Audio boundary (end of audio segment).
INTs | 5 | Introduction start time.
INTe | 6 | Introduction end time.
OUTs | 7 | Epilog start time.
OUTe | 8 | Epilog end time.
SECs | 9 | Secondary start time.
SECe | 10 | Secondary end time.
TERs | 11 | Tertiary start time.
TERe | 12 | Tertiary end time.
MRK | 13 | Generic marker.
EOD | 14 | End of data.


BitrateConstants enumeration

BitrateConstants enumeration

These are the constants for the Bitrate property (WavChunksEditor2).

Members

Part | Value | Description
BR_350_KBPS | 350 | 350 kbits per second.
BR_320_KBPS | 320 | 320 kbits per second.
BR_256_KBPS | 256 | 256 kbits per second.
BR_224_KBPS | 224 | 224 kbits per second.
BR_192_KBPS | 192 | 192 kbits per second.
BR_160_KBPS | 160 | 160 kbits per second.
BR_128_KBPS | 128 | 128 kbits per second.
BR_112_KBPS | 112 | 112 kbits per second.
BR_96_KBPS | 96 | 96 kbits per second.
BR_80_KBPS | 80 | 80 kbits per second.
BR_64_KBPS | 64 | 64 kbits per second.
BR_56_KBPS | 56 | 56 kbits per second.
BR_48_KBPS | 48 | 48 kbits per second.
BR_40_KBPS | 40 | 40 kbits per second.
BR_32_KBPS | 32 | 32 kbits per second.
BR_24_KBPS | 24 | 24 kbits per second.
BR_16_KBPS | 16 | 16 kbits per second.
BR_8_KBPS | 8 | 8 kbits per second.
BR_NONE | 0 | None.


ChannelsConstants enumeration

ChannelsConstants enumeration

These are the constants for the Channels property (WavChunksEditor2).

Members

Part | Value | Description
MONO | 1 | Mono data uses one channel.
STEREO | 2 | Stereo data uses two channels.


FrequencyConstants enumeration

FrequencyConstants enumeration

These are the constants for the Frequency property (WavChunksEditor2).

Members

Part | Value | Description
FQ_96_KHZ | 96000 | 96000 hertz.
FQ_88_KHZ | 88200 | 88200 hertz.
FQ_48_KHZ | 48000 | 48000 hertz.
FQ_44_KHZ | 44100 | 44100 hertz.
FQ_32_KHZ | 32000 | 32000 hertz.
FQ_24_KHZ | 24000 | 24000 hertz.
FQ_22_KHZ | 22050 | 22050 hertz.
FQ_16_KHZ | 16000 | 16000 hertz.
FQ_12_KHZ | 12000 | 12000 hertz.
FQ_11_KHZ | 11025 | 11025 hertz.
FQ_8_KHZ | 8000 | 8000 hertz.
FQ_6_KHZ | 6000 | 6000 hertz.


NCTWavChunksEditor2 structures

NCTWavChunksEditor2 structures

Structure | Description
ACMFormat | It is the structure for the FormatACM property.
BroadcastAudioExtension | It is the structure for the BroadcastAudioExtension property.
CartAudioExtension | It is the structure for the CartAudioExtension property.
CartAudioTimer | It is the structure for the CartAudioExtension structure.
CuePoint | It is the structure for the CuePointInfo property.
ExtraInformation | It is the structure for the ExtraInformation property.

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT Company Ltd. http://www.nctsoft.com


ACMFormat structure

ACMFormat structure

It is the structure for the FormatACM property.

Members

Part | Type | Description
cbSize | Integer | Specifies the size of the array of the extra information in the format header. For PCM format cbSize is equal to 0.
nAvgBytesPerSec | Long | Specifies the average data rate. Playback software can estimate the buffer size by using this value. For PCM format nAvgBytesPerSec is equal to (nBlockAlign*nSamplesPerSec).
nBlockAlign | Integer | Specifies the block alignment of the data, in bytes. Playback software must process a multiple of nBlockAlign bytes of data at a time, so that the value of nBlockAlign can be used for buffer alignment. For PCM format nBlockAlign is equal to (nChannels*wBitsPerSample/8).
nChannels | Integer | Specifies the number of channels in the audio array, 1 for mono, 2 for stereo.
nSamplesPerSec | Long | Specifies the frequency of the sample rate of the audio array in samples/second (Hz). Examples are 11,025, 22,050, or 44,100.
wBitsPerSample | Integer | Specifies the number of bits per sample per channel data. Each channel is assumed to have the same sample resolution. Can be 8 or 16.
wFormatTag | Integer | Defines the audio waveform type of the audio array. A complete list of format tags can be found in the Mmreg.h header file included with Microsoft® Visual C++® and other Microsoft products. For example, 1 - PCM, 6 - A-LAW, 7 - U-LAW, 80 - MPEG-2, 85 - MPEG-3.

Example:

' VB sample where WChEditor2 is an WavChunksEditor2 object.
Dim ACM As ACMFormat
ACM.wFormatTag = 1 'PCM format
ACM.wBitsPerSample = 8
ACM.nSamplesPerSec = 44,100
ACM.nChannels = 2
ACM.nBlockAlign = (ACM.nChannels*ACM.wBitsPerSample)/8 'Only for PCM format
ACM.nAvgBytesPerSec = ACM.nBlockAlign*ACM.nSamplesPerSec 'Only for PCM format
ACM.cbSize = 0 'for PCM format extra information is not used
WChEditor2.FormatACM = ACM

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT Company Ltd. http://www.nctsoft.com


BroadcastAudioExtension structure

BroadcastAudioExtension structure

It is the structure for the BroadcastAudioExtension property.

Members

Part

Type

Description

CodingHistory

String

String, containing a collection of strings terminated by CR/LF. Each string contains a description of a coding process applied to the audio data.

Each new coding application is required to add a new string with the appropriate information.

This information must contain the type of sound (PCM or MPEG) with its specific parameters :

PCM : mode (mono, stereo), size of the sample (8, 16 bits) and sample frequency:

MPEG : sample frequency, bit-rate, layer (I or II) and the mode (mono, stereo, joint stereo or dual channel).

It is recommended that the manufacturers of the coders provide an ASCII string for use in the coding history.

Description

String

String containing a free description of the sequence.

To help applications that display only a short description, it is recommended to use the first 64 characters for résumé of the description, and the last 192 characters are use for details.

OriginationDate

String

String containing the date of the creation of the audio sequence. The format is isyyyy-mm-ddlt (year-month-day).

Year is defined from 0000 to 9999

Month is define from 1 to 12.

Day is defined from 1 to 28,29,30 or 31

The separator between the items can be anything but it is recommended that one of the

following characters is used:

‚-‚ hyphen ‚_™ underscore ‚:™ colon ‚ ™ space ‚.™ stop

OriginationTime

String

String containing the time of the creation of the audio sequence. The format is ishh-mm-sslT (hours-minutes-seconds).

Hour is defined from 0 to 23.

Minute and second are defined from 0 to 59.

The separator between the items can be anything but it is recommended that one of the following characters is used:

‚-‚ hyphen ‚_™ underscore ‚:™ colon ‚ ™ space ‚.™ stop

Originator

String

String containing the name of the originator/producer of the audio file. If the length of the string is less than 32 characters, the field is ended by a null character.

OriginatorReference

String

String containing a non ambiguous reference allocated by the originating organization. If the length of the string is less than 32 characters, the field is ended by a null character.

TimeReferenceHigh

Long

First sample count since midnight, high word.

This field contains the timecode of the sequence. This value contains the first sample count since midnight.

TimeReferenceLow

Long

First sample count since midnight, low word.

This field contains the timecode of the sequence. This value contains the first sample count since midnight.

Version

Integer

An unsigned binary number giving the version of the BWF, particularly the contents of the Reserved field. For Version 1, this is set to 0001h.

Example:

' VB sample where WChEditor is an WavChunksEditor2 object.
'Gets broadcast information
Dim Broadcast As BroadcastAudioExtension
infoCodingHistory.Text = Broadcast.CodingHistory
infoDescription.Text = Broadcast.Description
infoOriginationDate.Text = Broadcast.OriginationDate
infoOriginationTime.Text = Broadcast.OriginationTime
infoOriginator.Text = Broadcast.Originator
infoOriginatorReference.Text = Broadcast.OriginatorReference
infoTimeReferenceHigh.Text = Broadcast.TimeReferenceHigh
infoTimeReferenceLow.Text = Broadcast.TimeReferenceLow
infoVersion.Text = Broadcast.Version

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT Company Ltd. http://www.nctsoft.com


CartAudioExtension structure

CartAudioExtension structure

It is the structure for the CartAudioExtension property.

Members

Part | Type | Description
Artist | String | String, holding the artist or creator name for the audio cut.
Category | String | String, holding the category name. The category name may be application dependent. Applications should use common category names.
Classification | String | String, holding a classification key. This key may be used for general classification, selection or sorting based on language, locale or other similar applications.
ClientID | String | String, holding the client or customer identification or name.
CutID | String | String, representing the cut number, or unique cut key. The string shall be left justified. Some consumer systems can have restricted cut number lengths or allowable character set. These applications should provide some means of synthesizing a usable cut identifier if it has such restrictions.
EndDate | String | As in start date, but shall indicate the date after which the sequence will no longer be active. If the sequence is to run forever, the date shall be "9999-12-31". There shall be no default for this field.
EndTime | String | This string shall indicate the time of the day on the appointed end date after which the sequence becomes inactive. If blank, applications shall assume the end time of "23:59:59".
LevelReference | Long | Value that shall hold the sample value of the 0-dB reference level for the originating system. This reference can facilitate scaling and metering consistency across disparate systems. As an example, a 16-bit linear PCM system that has its meters calibrated as 0 corresponding to maximum signed digital value shall have the value set to 32768. The peak value shall be the absolute value of the largest sample value possible before saturation. In the example given, that of a 16-bit linear system using 2’s complement notation, the range of allowable values is -32768 to 32767, thus the maximum peak value is 32768 in the example given.
OutCue | String | String, holding the optional out cue phrase to be displayed when the cut is being played. This shall be a user readable cue string.
PostTimer | CartAudioTimer | Eight CartAudioTimer structures representing time marks. These timers may be used to activate events in the cart system. If a timer is not used, or is not set, its usage identifier should be set to all NONE and its timer value set to 0.
ProducerAppID | String | String, containing the vendor name, product name or both of the program or application that produced the WAVE file with this cart chunk.
ProducerAppVersion | String | String, containing the version of the program or applications that produced the WAVE file containing the cart chunk. Because this string is informational only, the application may represent the version in any convenient format.
StartDate | String | String, of the form YYYY-MM-DD, such as "1998-12-25", holding the start date. Year (YYYY) shall be defined as 0000 to 9999. Month (MM) shall be defined as 01 to 12. Day (DD) shall be defined as 01 to 28, 29, 30 or 31 as applicable. The separator between date fields shall be a hyphen, (-). Note: This format complies with ISO 8601 and is compatible with other dates in BWF files. To signify an immediate start date, applications shall use "1900-01-01".
StartTime | String | String, of the form hh:mm:ss, such as 12:31:45, representing the 24-hour time-of-day for the start time on the assigned StartDate. Hour (hh) shall be defined as 00 to 23. Minutes (mm) and seconds (ss) shall be defined as 00 to 59. The separator between time fields shall be a colon, (:). If blank, applications shall assume a start time of "00:00:00".
TagText | String | String that contains a collection of strings each terminated by <CR><LF>. This text may be system- or user- defined descriptive text for the sound, such as live tag, script information, descriptive text special instructions, and so on.
Title | String | String, representing the title of the cut. The title should be a descriptive summary of the audio contents of the file, and may be used as an entry into a table of contents, and so on. Applications that do not support a 64-character title may truncate the field as needed.
URL | String | String, representing a universal resource locator (URL) referencing to or referenced by the audio program.
UserDef | String | String, the use and contents of which may be defined by the user of the system.
Version | String | String giving the version of the cart data structure, particularly the contents and usage of the reserved area. The first two numbers shall give the major release level (with leading 0) from 00 to 99 and the last two shall give the revision level (with leading 0) in the range of 00 to 99. The version number of the cart data structure as described in this document shall be version 1.01, and thus is represented by the string 0101.

Example:

' VB sample where WChEditor2 is an WavChunksEditor2 object.
'Gets cart audio extension
Dim Cart As CartAudioExtension
tArtist.Text = Cart.Artist
tCategory.Text = Cart.Category
tClassification.Text = Cart.Classification
tClientID.Text = Cart.ClientID
tCutID.Text = Cart.CutID
tEndDate.Text = Cart.EndDate
tEndTime.Text = Cart.EndTime
tLevelReference.Text = Cart.LevelReference
tOutCue.Text = Cart.OutCue
tProducerAppID.Text = Cart.ProducerAppID
tProducerAppVersion.Text = Cart.ProducerAppVersion
tStartDate.Text = Cart.StartDate
tStartTime.Text = Cart.StartTime
tTagText.Text = Cart.TagText
tTitle.Text = Cart.Title
tUrl.Text = Cart.URL
tUserDef.Text = Cart.UserDef
tVersion.Text = Cart.Version

cPostTimer.Clear
For i = 0 To 7
    cPostTimer.AddItem (i + 1) & " : " & PostTimer(Cart.PostTimer(i).Usage) & " - " & Int(Cart.PostTimer(i).Value / Frequency) & " sec"
Next i
cPostTimer.ListIndex = 0

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT Company Ltd. http://www.nctsoft.com


CartAudioTimer structure

CartAudioTimer structure

It is the structure for the CartAudioExtension structure.

Members

Part | Type | Description
Usage | BasicTimerConstants | Timer usage identifier.
Value | Long | Timer value in samples from head. The time units shall be in sample periods at the sampling frequency of the associated audio data and shall be referenced to the first sample of the audio data.

Example:

' VB sample where WChEditor2 is an WavChunksEditor2 object.
'Gets cart audio extension
Dim Cart As CartAudioExtension
tArtist.Text = Cart.Artist
tCategory.Text = Cart.Category
tClassification.Text = Cart.Classification
tClientID.Text = Cart.ClientID
tCutID.Text = Cart.CutID
tEndDate.Text = Cart.EndDate
tEndTime.Text = Cart.EndTime
tLevelReference.Text = Cart.LevelReference
tOutCue.Text = Cart.OutCue
tProducerAppID.Text = Cart.ProducerAppID
tProducerAppVersion.Text = Cart.ProducerAppVersion
tStartDate.Text = Cart.StartDate
tStartTime.Text = Cart.StartTime
tTagText.Text = Cart.TagText
tTitle.Text = Cart.Title
tUrl.Text = Cart.URL
tUserDef.Text = Cart.UserDef
tVersion.Text = Cart.Version

cPostTimer.Clear
For i = 0 To 7
    cPostTimer.AddItem (i + 1) & " : " & PostTimer(Cart.PostTimer(i).Usage) & " - " & Int(Cart.PostTimer(i).Value / Frequency) & " sec"
Next i
cPostTimer.ListIndex = 0

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT Company Ltd. http://www.nctsoft.com


CuePoint structure

CuePoint structure

It is the structure for the CuePointInfo property.

Members

Part | Type | Description
CodePage | Long | Marker code page.
Country | Long | Country identifier.
Dialect | Long | Dialect identifier.
Label | String | A short text label describing the cue or range.
Language | Long | The number of language.
Length | Long | Marker length. Can be 0 (cue marker) or more then 0 (range marker length), in samples.
Note | String | A note string.
Position | Long | A marker position, in samples.
Text | String | A text description of the cue or the range.

Example:

' VB sample where WChEditor2 is an WavChunksEditor2 object.
i = udCueIndex.Value
If i < CueCounts And i > 1 Then
    CuePoints(i).Position = Int(tPosition.Text)
    CuePoints(i).Length = tLength.Text
    CuePoints(i).Label = tLabel.Text
    CuePoints(i).Note = tNote.Text
    CuePoints(i).Text = tText.Text
End If

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT Company Ltd. http://www.nctsoft.com


ExtraInformation structure

ExtraInformation structure

It is the structure for the ExtraInformation property.

Members

Part | Type | Description
Album | String | The album name.
ArchivalLocation | String | Indicates where the subject of the file is archived.
Artist | String | Lists the artist of the original subject of the file. For example, “Michelangelo.”
Comments | String | Provides general comments about the file or the subject of the file. If the comment is several sentences long, end each sentence with a period. Do not include new line characters.
Commissioned | String | Lists the name of the person or organization that commissioned the subject of the file. For example, “Pope Julian II.”
Copyright | String | Records the copyright information for the file. For example, “Copyright Encyclopedia International 1991.” If there are multiple copyrights, separate them by a semicolon followed by a space.
Cropped | String | Describes whether an image has been cropped and, if so, how it was cropped. For example, “lower right corner.”
Dimensions | String | Specifies the size of the original subject of the file. For example, “8.5 in h, 11 in w.”
DotsPerInch | String | Stores dots per inch setting of the digitizer used to produce the file, such as “300.”
EncodedBy | String | Type of encoder.
Engineer | String | Stores the name of the engineer who worked on the file. If there are multiple engineers, separate the names by a semicolon and a blank. For example, “Smith, John; Adams, Joe.”
Genre | String | Describes the original work, such as, “landscape,” “portrait,” “still life,” etc.
Keywords | String | Provides a list of keywords that refer to the file or subject of the file. Separate multiple keywords with a semicolon and a blank. For example, “Seattle; aerial view; scenery.”
Lightness | String | Describes the changes in lightness settings on the digitizer required to produce the file. Note that the format of this information depends on hardware used.
Medium | String | Describes the original subject of the file, such as, “computer image,” “drawing,” “lithograph,” and so forth.
Name | String | Stores the title of the subject of the file, such as, “Seattle From Above.”
PaletteSetting | String | Specifies the number of colors requested when digitizing an image, such as “256.”
Product | String | Specifies the name of the title the file was originally intended for, such as “Encyclopedia of Pacific Northwest Geography.”
Sharpness | String | Identifies the changes in sharpness for the digitizer required to produce the file (the format depends on the hardware used).
Source | String | Identifies the name of the person or organization who supplied the original subject of the file. For example, “Trey Research.”
SourceForm | String | Identifies the original form of the material that was digitized, such as “slide,” “paper,” “map,” and so forth. This is not necessarily the same as IMED.
Subject | String | Describes the conbittents of the file, such as “Aerial view of Seattle.”
Technician | String | Identifies the technician who digitized the subject file. For example, “Smith, John".
Title | String | The file's title.
Track | String | Number of track.
Year | String | The year when the audio file subject was created.

Example:

' VB sample where WChEditor2 is an WavChunksEditor2 object.
Dim Info As ExtraInformation
infoAlbum.Text = Info.Album
infoArchivalLocation.Text = Info.ArchivalLocation
infoArtist.Text = Info.Artist
infoComment.Text = Info.Comments
infoCommissioned.Text = Info.Commissioned
infoCopyright.Text = Info.Copyright
Info.Comments = infoComment.Text
infoEncodedBy.Text = Info.EncodedBy
infoEngineer.Text = Info.Engineer
infoGenreS.Text = Info.Genre
infoName.Text = Info.Name
infoProduct.Text = Info.Product
infoSource.Text = Info.Source
infoSourceForm.Text = Info.SourceForm
infoSubject.Text = Info.Subject
infoTechnician.Text = Info.Technician
infoTitle.Text = Info.Title
infoTrack.Text = Info.Track
infoYear.Text = Info.Year

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT Company Ltd. http://www.nctsoft.com


NCTWavChunksEditor2Lib

Version

Version

NCTWavChunksEditor 2.2 Type Library

The NCTWavChunksEditor2 consists of the following objects:

Objects
WavChunksEditor2

You can use the NCTWavChunksEditor2 in your program, written on the language, which supports ActiveX automation.

The NCTWavChunksEditor2 was tested with:

  • MS Visual Basic 6.0 (SP5);

  • MS Visual C++ 6.0 (SP5);

  • Borland C++ Builder 5.0;

  • Borland Delphi 6.0.

under Windows 98/Me/NT/2000/XP

SYSTEM REQUIREMENTS:

  • Windows 98/Me/NT/2000/XP;

  • MS Visual Basic 6.0 or MS VC++ 6.0 (SP5).


WavChunksEditor2

WavChunksEditor2 object

WavChunksEditor2 Class

Send Feedback on the NCTWavChunksEditor2 documentation.
NCTWavChunksEditor2 was developed by NCT company http://www.nctsoft.com